celestical.me - Service Degradation Affecting Client login, AI Chat Compose, Meeting joining features & Dashboards in the Europe Region – Incident details

All systems operational

Service Degradation Affecting Client login, AI Chat Compose, Meeting joining features & Dashboards in the Europe Region

Resolved
Operational
Started 3 months agoLasted about 12 hours

Affected

Video Conferencing Connections

Operational from 1:31 PM to 1:31 AM

Zoom

Operational from 1:31 PM to 1:31 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved and the affected services have been restored.

  • Monitoring
    UTC
    Monitoring

    On 4/14/2026 between 12:28 UTC to 12:58 UTC, a subset of users may have experienced issues with Client login, AI Chat Compose, Meeting joining features & Dashboards in the Europe Region. Will continue to monitor the services.

    This incident has been resolved and the affected services have been restored. Thank you for your patience.

  • Investigating
    UTC
    Investigating

    On 4/14/2026 between 12:28 UTC to 12:58 UTC, a subset of users may have experienced issues with Client login, AI Chat Compose, Meeting joining features & Dashboards in the Europe Region.

    This incident has been resolved and the affected services have been restored.